Tuto: Comment décoder le DTS sur un NAS Synology

De base, un NAS Synology avec la suite d’applications fournies, ne décode pas le DTS, pour une question de droits. Nous allons résoudre le problème en moins de 10 minutes chrono.

Ce tuto a été réalisé avec DSM 6.0.2 mais doit également fonctionner sur DSM 5.x sous toute réserve.

Etape par étape: comment activer le décodage du DTS pour les vidéos avec un NAS Synology.

La première étape consiste a vérifier quel est le modèle de votre NAS Synology. Vous le trouverez dans le panneau de configuration puis centre d’infos.

Ensuite, vous allez sur cette page, pour vérifier quelle est l’architecture de votre modèle de NAS. Par exemple, un DS416 play fait partie de la génération Braswell.

Ensuite, vous allez télécharger le fichier suivant, en suivant ce lien. Si vous avez des difficultés à télécharger le fichier, merci de me le signaler.

Décompressez le fichier « For DSM 5.zip« , pas d’inquiétude, ça fonctionne aussi pour DSM 6.

Vous devriez avoir une liste de fichier de la forme:

FFmpegWithDTS-générationdeCPU-1.0-0005.spk

Sélectionnez le fichier correspondant à votre NAS et mettez le de côté. Vous pouvez effacer les autres.

Nous allons maintenant installer le package. Pour cela il suffit d’aller le centre de packages. 

Choisissez installation manuelle et sélectionnez le fichier de package mis de côté.

Installation Paquet DTS Synology

Cliquez sur Suivant puis Appliquer.

C’est terminé, votre NAS Synology décode désormais le DTS. Cela fonctionne pour toutes les applications qui sont basées sur le package « Serveur Multimédia« , à savoir le DLNA, Vidéo Station et les apps DS Vidéo.

Note: la source est ce blog Taiwainais, vous y trouverez également un lien pour des packages compatibles avec DSM 4.3, mais sans aucune garantie. Merci à Mowd Chen pour le travail accompli.

D’autres articles pour votre serveur NAS Synology

Tuto: Comment streamer ou lire des vidéos depuis un NAS Synology ou comment créer votre mini Netflix privé.

Tuto: installer son propre serveur VPN sur un NAS Synology en quelques minutes

Le test du serveur NAS Synology DS916+

Choisir un onduleur pour son Nas Synology

 

 

Ma sélection de NAS Synology

  • Thanks for trackback my blog. By the way, this blog and I are from Taiwan, not China.
    https://fr.wikipedia.org/wiki/Ta%C3%AFwan

    • Oh, i’m really sorry. I corrected my mistake. By the way, thanks for the good work.

    • Oh, i’m really sorry. I corrected my mistake. By the way, thanks for the good work.

  • nialanittoc

    Bonjour, impossible de faire la manip, lorsque j’ai sélectionné le fichier qui est semblable au votre,
    et que j’appuie sur suivant, le message suivant apparait : «  » Ce paquet ne contient pas une signature numérique «  » et la manip échoue….Que faut-il faire d’autre !!!!!!Cordialement AC
    J’ai un synology DS916+ 8Go

    • Bonjour,
      Je pense que dans le centre de paquets, dans Paramètres, il faut sélectionner l’option « N’importe quel éditeur » pour le niveau de confiance.

      J’ai également un DS916+ 8Go et cela fonctionne parfaitement.

    • En réponse à nialanittoc.
      Bonjour,
      Je pense que dans le centre de paquets, dans Paramètres, il faut sélectionner l’option « N’importe quel éditeur » pour le niveau de confiance.

      J’ai également un DS916+ 8Go et cela fonctionne parfaitement.

  • Emmanuel Burguete

    Bonjour,

    Mon NAS est un DS715
    Annapurna Labs Alpine AL-314
    Quad Core
    4
    Yes
    Alpine
    DDR3 2 GB

    Je ne trouve pas l’alpine dans la liste…
    Auriez vous une idée pour moi?

    Merci !!!
    Emmanuel

    • Ton processeur est basée sur une architecture ARM V7, tu peux donc tenter ta chance avec le paquet armada370 ou 375… sans aucune assurance.

      • Emmanuel Burguete

        Merci! Je vais essayer cela. Je te tiens au courant.

        • Alors ça fonctionne?

          • Emmanuel Burguete

            Je n’ai pas réussi… et depuis je ne mes suis pas replongé dans le pb.

  • wattoo wattoo

    Bonjour. J’ai un DS418 play et ça ne fonctionne pas. J’ai téléchargé le fichier pour un x86-64 car le dernier Intel de mon DS n’y figure pas. De plus le paquet Plex n’est pas dispo, j’ai donc un syno qui ne me sers à rien pour l’instant pour les vidéos en DTS et DD true HD….

    • Salut,
      Effectivement, le développeur a des problèmes pour compiler le package sur les dernières versions.
      Par contre, tu peux tout à fait installer Plex avec les tutos Docker que j’ai fait, ça marche très bien.
      Tu lis tes vidéos sur quel devices?
      Ce week-end, je vais essayer de vous faire un nouveau tuto pour les périphériques iOS et Apple TV.

      • wattoo wattoo

        Merci beaucoup de votre réponse. Je vais essayer Docker ou attendre que Plex mettre à jour le paquet.
        Je lis les vidéos sur iPad de 4e génération ou iPhone 5C pour pouvoir les « caster » sur Chromecast sur ma TV puisque DS Vidéo propose cette option. J’ai des back up de mes Blue-Ray donc ils sont soient en MKV avec une piste audio en DTS ou DTS HD ou DD True HD, ou ce sont des .MTS.

        Merci pour le tuto. Je vais le lire avec intérêt.

  • Conan LeBarbare

    Merci pour le tuto.
    Marche nickel sur 918+ (architecture x86_64) + DSM 6.1.4-15217 Update 2.

    • totophe

      mince meme architecture sur le ds118, mais cela ne marche pas…

      • Conan LeBarbare

        Le ds118 n’a pas la même architecture que le ds918+. L’architecture du ds118 est de type armv8.

  • Kamel Zagger

    Merci pour le tuto, ça fonctionne très bien sur mon DS918+.

    Par contre es normal que ce plugin (codec) prenne autant de ressources sur le processeur ?

    Je suis souvent dans le rouge vers les 95%.

    Il y à t-il une solution ?

    https://uploads.disquscdn.com/images/9b5245f5900b0e90d702c7c8a5fffc76879b4ec37436d756cd3d234fa2e4ff69.png

    • Non pas normal du tout si tu n’es pas en lecture ou transcodage, essaie de redémarrer. Sinon si tu lis une vidéo HD ce n’est pas totalement étonnant.
      ffmpeg ce n’est pas le codec mais le processus qui décode – recode la vidéo…

      • Kamel Zagger

        Merci pour la réponse ! Oui je parle de quand je suis en lecture d’une vidéo en HD. Il me semblait que c’était un peu beaucoup… J’ai redémarré mon serveur mais c’est la même chose.

  • zorro3210

    J’ai un DS418. Je n’arrive à identifier le armv8. Quelqu’un pour m’aider svp? merci

  • Romain

    salut je comprends toujours pas comment cela marche chez vous. J’ai le DS416play, j’ai téléchargé le braswell , fait l’install nickel. Mais il me met toujours audio non supporté lorsque je lance la lecture depuis DS Video en DLNA vers ma TV panasonic. Je comprends pas !

  • Thierry Camprubi

    J’ai un Synology 216Play et je ne trouve pas le processeur dans la liste (Monaco). Une idée ?